Оптимизация работы с Cakewalk ProAudio 9.03

Алексей Доровской

Во все времена удобство считалось и считается одним из главных качеств программного обеспечения. Программ для создания музыки на PC существует великое множество, но у каждой из них есть свои приверженцы. Я начал работать с компьютером, когда появился на свет Cakewalk 3.0. И случилось так, что все мое творчество создавалось и создается именно в этой программе. Время идет, прогресс двигается вперед, кто-то осваивает Sonar, кто-то привык работать и работает в восьмой версии, но тем не менее информация, которая содержится в этой статье будет полезна для пользователей всех версий Cakewalk, так как интерфейс и опции настроек программы остаются схожими во всех версиях. Я же для примера возьму версию 9.03, как наиболее распространенный вариант.

При работе над аранжировкой очень важно сконцентрироваться на самой музыке, и очень легко потерять хорошую мысль, отвлекшись на поиск нужной функции или кнопки. Особенно это волнует начинающих пользователей программы, так как нет необходимой систематики. И я хочу предложить один из вариантов настройки программы, который формировался у меня в течение нескольких лет. Конечно, у большинства из нас программа уже настроена на свой лад, но это не запрещает мне поделиться своим опытом с остальными.

Представим себе, что мы только что установили Cakewalk, и программа имеет свой стандартный вид. Первым делом давайте настроим основное окно Track View. Щелкнем правой кнопкой мыши в правой части окна и увидим меню, из которого выберем пункт View Options. Здесь находятся самые основные настройки окна Track. Давайте разберемся, что означает каждый из этих пунктов:

Display Vertical Rules : Отображать вертикальные линии в окне Track.

Display Clip Names : Отображать название клипов MIDI и WAVE дорожек.

Display Clip Contents : Графическое отображение содержимого клипов.

Right Click Sets Now : Клик правой кнопки мыши будет устанавливать текущую позицию.

Опция Display Vertical Rules по умолчанию почему-то отключена, хотя я считаю, что без вертикальных линий, отделяющих такты друг от друга, работать очень неудобно. Поэтому давайте сразу поставим здесь галочку и включим ее. Опция Display Clip Names у меня отключена, так как названия клипов особой информативности не несут, если, конечно, не переименовывать клип после каждого дубля. А если клипов много, то на слабых машинах это просто лишняя загрузка процессора, не оправдывающая себя. Display Clip Contents – включает графическое отображение содержимого клипа. Это, разумеется, очень важный момент для визуального восприятия, поэтому включим ее. Последняя опция (Right Click Sets Now), как говорится, на любителя, кому как удобно. Это не особо важный момент.

Секцию Double-Click to open View мы изменять не будем.

Нажмем ОК для подтверждения изменений.

Теперь займемся настройкой левой части основного окна.

На мой взгляд, порядок столбцов по умолчанию является крайне неудобным, если не сказать непригодным. Тем не менее, некоторые пользователи не знают о том, что их последовательность можно изменить. Для этого достаточно ухватиться мышкой за название столбца и передвинуть на другой столбец, место которого он должен будет занять. Это особенно актуально для тех, у кого размер рабочего стола не превышает 800х600, и невозможно видеть все столбцы одновременно, поэтому и приходится отдавать предпочтение наиболее используемым. Я рекомендую расположить их в следующей последовательности:

Name, Patch, M, S, R, Vol, Pan, Chn, Source, Bank, Port, Effects, Key+, Vel+, Time+, Size.

Здесь наиболее часто используемые параметры стоят на первом месте, а наименее – на последнем. Разумеется, это всего лишь моя точка зрения.

Далее давайте настроим панель ToolBar. Для этого нажмем правую кнопку мыши на любой кнопке тулбара и увидим всплывающее меню его настройки. Большинство из панелей нам не понадобится, так как мы пойдем другим путем и чуть позже для быстрого доступа назначим быстрые клавиши. А лишнего места на экране они занимают достаточно. Итак, снимем галочки со всех панелей из этого списка, и оставим только Metronome, Position, Select, Tempo и Transport. А теперь расположим их так, чтобы при разрешении 800х600 они занимали не более двух строк. Для этого нужно ухватиться за двойную полосу в левой части панели, и, не отпуская, переместить на новое место. У меня на верхней строке помещаются Position, Transport, Select и Tempo. Нижнюю строку занимает Metronome. Оставшееся место в нижней строке можно использовать для помещения других панелей по выбору.

Ну вот, внешний вид основного окна мы почти настроили. Для истинных гурманов могу посоветовать залезть в меню Options > Colors и поэкспериментировать с цветовыми настройками, что, кстати, при длительной работе может достаточно благотворно повлиять на психику и снять стресс (на себе проверял).

Теперь займемся системными настройками Кейка. Войдем в меню Options > Global. По умолчанию нам открывается одноименная вкладка Global. Расшифрую эти названия:

Show Tooltips : Показать всплывающие подсказки к кнопкам тулбара.

Show Status Bar : Показать строку состояния (внизу окна).

Show MIDI Activity on Windows Taskbar : Показать индикатор сигналов миди в системной панели Windows (рядом с часами).

Display Gradient Backgrounds : Использовать градиентные цвета в качестве фона при отображении окон.

Display all times as SMPTE : Отображать все временные позиции в стандарте SMPTE.

Allow only one open project at time : Позволяет открывать только один проект одновременно.

Allow MIDI Recording without an Armed Track : Позволяет не использовать кнопку ARM для записи МИДИ.

Ask before sending System Exclusive : Позволяет выводить подтверждение перед посылом Системных сообщений (SYSEX) в порт.

Always use Sysx Banks for Midi Files : Использовать SYSEX-банки вместо SYSEX-сообщений.

Write Cable Meta Events : Позволяет прописывать в миди-файл информацию о портах для каждого канала.

Из этих опций хотел бы обратить ваше внимание на опцию Allow MIDI Recording without an Armed Track. На музыкальных форумах задается много вопросов по этому поводу. Поясню: когда эта опция выключена, то для того чтобы записать миди-информацию на дорожку с миди-клавиатуры вам потребуется нажать кнопку Arm (R в строке дорожки). Иначе запись производиться не будет. Это бывает удобно в основном для многоканальной миди-записи, а в обычном случае может сильно мешать. Я рекомендую поставить здесь галочку, чтобы не нажимать каждый раз на кнопку Arm. Примечание: даже если мы поставим здесь галочку, то это будет применимо только для МИДИ-записи. Для записи цифрового аудио вам все равно придется нажимать кнопку Arm.

Другая важная опция здесь – это Display Gradient Backgrounds. Ее отключение позволяет несколько увеличить быстродействие на слабых машинах. Эта функция носит чисто визуальный характер, поэтому если у вас слабый процессор или видеокарта, то рекомендую снять эту галочку.

Несколько слов по поводу автоматического сохранения проекта (Autosave). Думаю, не нужно рассказывать насколько это полезная функция. Если кто не знает, объясню: Кейк автоматически сохраняет ваш проект либо по совершении какого-либо изменения, либо по истечении определенного времени. Это удобно тем, что в случае ошибки программы или зависания компьютера Вам не придется выполнять всю работу заново. Проект сохраняется под именем “Autosave copy of _имя вашего проекта_.wrk”, так что ваш оригинальный проект не уничтожается этими изменениями. Поэтому я рекомендую настроить эту функцию так: Autosave every 0 minutes, 3 changes. Это оптимальный вариант. Если ваша машина часто виснет (типун мне на язык), то вы можете поставить 1 minutes, 1 changes. В этом случае проект будет сохраняться после каждого вашего изменения, и вдобавок еще и каждую минуту работы.

Остальные опции трогать не будем. Нажимаем ОК.

Теперь приступим к главному – назначению быстрых клавиш. Здесь я хочу сделать небольшое отступление и объяснить для чего все это. Главной моей целью является сокращение всех движений, которые мы совершаем мышью при работе с программой. И не только мышью. Например, один мой знакомый, хоть и хороший аранжировщик, но тем не менее до сих пор, чтобы добавить или убрать громкость клипа с цифровым аудио, экспортирует клип в Sound Forge, затем использует Volume, и делает возврат в Cakewalk. Все мои советы по поводу сокращения ненужных движений ни к чему не привели под прикрытием того, что он, мол, так привык, и ему так удобно. Что ж, привык так привык, но нетрудно представить, сколько времени он теряет на все эти ненужные манипуляции, в то время как обойтись можно простым нажатием кнопки, тем более, что изменение громкости отдельного клипа – процедура нередкая. Поэтому далее я представлю свой вариант раскладки клавиатуры для использования. Я использую здесь только самые необходимые функции, чтобы можно было легко все запомнить.

Итак, зайдем в меню Options > Key Bindings. В левом списке мы будем выбирать сочетание клавиш, а справа назначать им функцию и нажимаем кнопку Bind. Я не буду располагать свое перечисление в порядке важности функций, лучше это сделать по порядку клавиш, чтобы было удобнее вводить информацию:

Ctrl+A – View > Audio

Ctrl+B – Edit > Audio > Combine

Ctrl+E – View > Event List

Ctrl+F – View > Studioware

Ctrl+G – View > Console

Ctrl+I – Insert > Wave File

Ctrl+M – Insert > Marker

Ctrl+N – View > Staff

Ctrl+P – View > Piano Roll

Ctrl+Q – Edit > Quantize

Ctrl+W – Edit > Create Clips

F4 – Options > SoundFonts (для пользователей SBLive!)

Ctrl+F5 – MIDI Quieter 3units.cal*

Shift+F5 - MIDI Quieter 10units.cal*

Ctrl+F6 - MIDI Louder 3units.cal*

Shift+F6 - MIDI Louder 10units.cal*

Ctrl+F7 – MIDI Limiter.cal**

Shift+F8 – Fix velocity.cal**

F7 – Go > From

F8 – Go > Thru

F9 – Go > Previous Measure

F10 – Edit > Select > Thru = Now***

F11 – Edit > Select > From = Now***

F12 – Go > Next Measure

* - Эти клавиши у меня служат для быстрой коррекции громкости выделенного участка. Для этой цели используются маленькие скрипты на встроенном языке CAL (Cakewalk Application Language), написанные мной. В сети можно найти много аналогов этих скриптов, но я их написал сам, потому что: во-первых хотелось разобраться с CAL, а во вторых сделал их так, что при выполнении они не выводят никаких окон для подтверждения. Это позволяет использовать их в реальном времени по типу “больше-меньше”. Клавиши F5 и F6 в сочетании с Ctrl или Shift позволяют уменьшать(F5)/прибавлять(F6) громкость выделенного мышкой участка, причем в сочетании с Ctrl происходит более точная регулировка (на 3 ед.), а с Shift более грубая (на 10 ед.). Запомнить легко: сама кнопка Shift больше по размеру – изменение более заметно, Ctrl – меньше – изменение тоже меньше. Эти функции также действуют на клипы с цифровым аудио.

** - MIDI Limiter – скрипт, который позволяет выполнять функцию лимитера, только для миди. Принцип такой: Вас спросят, какое максимальное значение velocity допустимо. Введите его. В результате обработки все ноты, громкость которых меньше указанного значения останутся без изменений, а те, громкость которых больше – изменят ее на введенную. Fix velocity – совсем элементарно: введете цифру, и после этого все ноты выделенного участка изменят громкость на это значение.

*** - Это сочетание на мой взгляд, конечно, немного не логично: логичнее было бы на F10 назначить From=Now, а на F11 – Thru=Now, но Кейк, начиная с 8 версии, не правильно понимает это сочетание, всвязи с уже прошитыми в него установками. Поэтому Вы можете выбрать себе другие клавиши, если хотите.

Итак, я описал все настройки, необходимые для продуктивной работы. Еще раз повторюсь и скажу, что я, разумеется, не утверждаю, что это правильно и необходимо, но вполне возможно, что кому-нибудь пригодится. В любом случае, я с удовольствием отвечу на все вопросы, так или иначе касающиеся этой замечательной программы.